the tado cloud hub is experiencing problems, customers are unable to open the app

Incident Report for tado GmbH

Postmortem

Yesterday evening, between around 18:00 and 21:30 CET, tado° backend systems encountered a major outage. The result was that the tado° app was not responding and the Smart Schedule was not working either. However, setting manual control on the tado° thermostats was not affected and working fine for our customers.

The reason for the outage was due to a change we made in our main database. We were trying to improve the model of our data to help keep our apps more maintainable and efficient. This change, however, made it difficult for the database to respond to the high load that it gets from our devices and apps. This was an unintentional human error, which is difficult to avoid.

Since the beginning of the incident, our development team was working hard to resolve the issue. The reason why it took longer than expected for the issue to be resolved was that it was difficult to pin down the problem. There was no apparent relationship between the change we made and how the database was performing.

We followed a process of elimination to find the root cause of the issue and because the issue was caused by an unlikely culprit, it took us longer to find. Once the issue was found, the resolution was swift.

We want you to know that we take the performance and reliability of tado° seriously. We learn from such mistakes to ensure that we can respond to them in the best way possible and mitigate the effect they have on our customer base.

We’re always striving to optimise the way we communicate with our customers and we appreciate all the feedback you gave us during this incident.

You can find more information about how you can control your heating system on the tado° thermostats themselves in this article: https://support.tado.com/hc/en-gb/articles/207704943

We are very sorry for any inconvenience this may have caused.

Your tado° Team

Posted Mar 17, 2020 - 18:27 CET

Resolved

All of our services are up & running.
Thank you for your patience!
Posted Mar 16, 2020 - 22:11 CET

Update

We have some good news - our main services are up & running! We are continuing to work on getting the remainder of our services back up. We would like to thank you for your continued patience with us.
Posted Mar 16, 2020 - 21:43 CET

Identified

The issue has been identified and a fix is being implemented. We're expecting to be operational quite soon!
Posted Mar 16, 2020 - 21:07 CET

Investigating

We are currently investigating this issue.
Posted Mar 16, 2020 - 18:11 CET
This incident affected: Smart Device Control.